No se puede instalar la window acoplable

Estoy tratando de hacer tejido Hyperledger (configuration del entorno) y se requiere docker. Traté de search en el Internet de resolver para instalar la window acoplable, pero fue en vano. Los siguientes son los errores encontrados cuando intenté instalar dockers.

En git bash (git) intenté usar sudo apt-get install docker-engine . Pero dice

 Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some requinetworking packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: Docker-engine: Depends: init-system-helpers (>= 1.13~) but it is not installable Depends: sysv-rc (>= 2.88dsf-24) but 2.88dsf-13.10ubuntu11 is to be installed or file-rc (>= 0.8.16) but it is not installable Depends: libc6 (>= 2.17) but 2.15-0ubuntu10 is to be installed Depends: libdevmapper1.02.1 (>= 2:1.02.63) but 2:1.02.48-4ubuntu7 is to be installed Depends: libsystemd-journal0 (>= 201) but it is not installable Recommends: aufs-tools but it is not going to be installed Recommends: cgroupfs-mount but it is not installable or cgroup-lite but it is not going to be installed Recommends: git but it is not going to be installed E: Unable to correct problems, you have held broken packages. 

He seguido cada paso de este website en la installation de Docker: https://docs.docker.com/engine/installation/linux/ubuntulinux/

Este es el website en el que he intentado build un tejido hyperledger (en la etapa de construcción fuera de vagrant, instalando docker): http://hyperledger-fabric.readthedocs.io/en/latest/dev-setup/build/

Limpie el repository de packages no válido:

 cd ../../etc/apt/sources.list.d sudo rm docker.list 

Luego agrega el repository y actualiza:

 sudo apt-add-repository 'deb https://apt.dockerproject.org/repo ubuntu-xenial main' sudo apt-get update sudo apt-get install docker-engine 

Tal vez esta página puede ayudarte Descarga de package: libsystemd-journal0

Puede download cierto file deb e instalarlo usando el command dpkg , pero aún puede haber algunos problemas de dependencia. Así que será mejor que modifiques tu file /etc/apt/source.list según esta página (si necesitas una versión de 64 bits).

En cuanto a libsystemd-journal0

Puede agregar la siguiente línea después de la queue de /etc/apt/sources.list

deb http://cz.archive.ubuntu.com/ubuntu trusty main

entonces

 sudo apt-get update 

Supongo que otros problemas de dependencia se pueden resolver de manera similar.

Lo siento, mi habilidad en inglés no es buena.

Agregue backports a su repository de apt: "deb http://ftp.de.debian.org/debian wheezy-backports main"

y realizar un:

 sudo apt-get update 

Después,

 sudo apt-get install docker-engine 

debe completar bien