Las firmas no se pudieron verificar porque la key pública no está disponible al momento de instalar Docker

No se puede instalar la window acoplable con:

sudo sh -c "echo deb https://get.docker.com/ubuntu docker main > /etc/apt/sources.list.d/docker.list" 

logging de errores:

Error de GPG: https://get.docker.com Docker Lanzamiento: las siguientes firmas no se pudieron verificar porque la key pública no está disponible: NO_PUBKEY D8576A8BA88D21E9

Si no desea utilizar esos commands del manual http://docs.docker.com/linux/step_one/ :

 $ sudo apt-get update $ sudo apt-get install wget $ wget -qO- https://get.docker.com/ | sh 

hay lo que necesitas:

  $ wget -qO- https://get.docker.com/gpg | sudo apt-key add - 

PD: https://docs.docker.com/installation/debian/

Tengo la solución, estaba tratando de instalar docker 1.5 en un Ubuntu de 32 bits, mientras que la documentation dice que necesita Ubuntu de 64 bits.

mira aquí en la sección de Requisitos previos

Parece que la página de inicio ha cambiado.

Ago 2017

curl -fsSL https://download.docker.com/linux/debian/gpg | sudo apt-key add -

https://docs.docker.com/engine/installation/linux/docker-ce/debian/#install-using-the-repository