La implementación de Mupx falla. ¿Por qué?

Estoy tratando de implementar Telescope en un simple server Ubuntu 16.04. Así que estoy usando la implementación sugerida con MupX . Después de configurar el file mup.json, hice un mupx deploy :

 $ mupx setup Meteor Up: Production Quality Meteor Deployments ------------------------------------------------ Configuration file : mup.json Settings file : settings.json Started TaskList: Setup (linux) [146.185.181.9] - Installing Docker [146.185.181.9] - Installing Docker: SUCCESS [146.185.181.9] - Setting up Environment [146.185.181.9] - Setting up Environment: SUCCESS [146.185.181.9] - Copying MongoDB configuration [146.185.181.9] - Copying MongoDB configuration: SUCCESS [146.185.181.9] - Installing MongoDB [146.185.181.9] - Installing MongoDB: SUCCESS 

No hay problemas allí, así que después de esto probé una mupx deploy , pero eso termina con un error:

 $ mupx deploy Meteor Up: Production Quality Meteor Deployments ------------------------------------------------ Configuration file : mup.json Settings file : settings.json Meteor app path : /Users/kramer65/dev/repos/Telescope Using buildOptions : {} nova:rss: updating npm dependencies -- rss... Changes to your project's package version selections: reactrouter:react-router-ssr downgraded from 3.1.4 to 3.1.3 Started TaskList: Deploy app 'telescope' (linux) [146.185.181.9] - Uploading bundle [146.185.181.9] - Uploading bundle: SUCCESS [146.185.181.9] - Sending environment variables [146.185.181.9] - Sending environment variables: SUCCESS [146.185.181.9] - Initializing start script [146.185.181.9] - Initializing start script: SUCCESS [146.185.181.9] - Invoking deployment process [146.185.181.9] - Invoking deployment process: SUCCESS [146.185.181.9] - Verifying deployment [146.185.181.9] x Verifying deployment: FAILED -----------------------------------STDERR----------------------------------- run: npm WARN deprecated npm WARN deprecated npm -g install npm@latest npm WARN deprecated npm WARN deprecated (Depending on how Node.js was installed on your system, you npm WARN deprecated may need to prefix the preceding commands with `sudo`, or if npm WARN deprecated on Windows, run them from an Administrator prompt.) npm WARN deprecated npm WARN deprecated If you're running the version of npm bundled with npm WARN deprecated Node.js 0.10 LTS, be aware that the next version of 0.10 LTS npm WARN deprecated will be bundled with a version of npm@2, which has some small npm WARN deprecated backwards-incompatible changes made to `npm run-script` and npm WARN deprecated semver behavior. npm WARN package.json meteor-dev-bundle@0.0.0 No description npm WARN package.json meteor-dev-bundle@0.0.0 No repository field. npm WARN package.json meteor-dev-bundle@0.0.0 No README data > fibers@1.0.8 install /bundle/bundle/programs/server/node_modules/fibers > node build.js || nodejs build.js -----------------------------------STDOUT----------------------------------- To see more logs type 'mup logs --tail=50' ---------------------------------------------------------------------------- 

Así que revisé lo que decían los loggings:

 $ mupx logs --tail=50 Meteor Up: Production Quality Meteor Deployments ------------------------------------------------ Configuration file : mup.json Settings file : settings.json [146.185.181.9] at fileEvaluate (packages/modules-runtime/.npm/package/node_modules/install/install.js:141:1) [146.185.181.9] at require (packages/modules-runtime/.npm/package/node_modules/install/install.js:75:1) [146.185.181.9] at packages/react-meteor-data/createContainer.jsx:10:16 [146.185.181.9] npm WARN deprecated This version of npm lacks support for important features, [146.185.181.9] npm WARN deprecated such as scoped packages, offenetworking by the primary npm [146.185.181.9] npm WARN deprecated registry. Consider upgrading to at least npm@2, if not the [146.185.181.9] npm WARN deprecated latest stable version. To upgrade to npm@2, run: [146.185.181.9] npm WARN deprecated [146.185.181.9] npm WARN deprecated npm -g install npm@latest-2 [146.185.181.9] npm WARN deprecated [146.185.181.9] npm WARN deprecated To upgrade to the latest stable version, run: [146.185.181.9] npm WARN deprecated [146.185.181.9] npm WARN deprecated npm -g install npm@latest [146.185.181.9] npm WARN deprecated [146.185.181.9] npm WARN deprecated (Depending on how Node.js was installed on your system, you [146.185.181.9] npm WARN deprecated may need to prefix the preceding commands with `sudo`, or if [146.185.181.9] npm WARN deprecated on Windows, run them from an Administrator prompt.) [146.185.181.9] npm WARN deprecated [146.185.181.9] npm WARN deprecated If you're running the version of npm bundled with [146.185.181.9] npm WARN deprecated Node.js 0.10 LTS, be aware that the next version of 0.10 LTS [146.185.181.9] npm WARN deprecated will be bundled with a version of npm@2, which has some small [146.185.181.9] npm WARN deprecated backwards-incompatible changes made to `npm run-script` and [146.185.181.9] npm WARN deprecated semver behavior. [146.185.181.9] npm WARN package.json meteor-dev-bundle@0.0.0 No description [146.185.181.9] npm WARN package.json meteor-dev-bundle@0.0.0 No repository field. [146.185.181.9] npm WARN package.json meteor-dev-bundle@0.0.0 No README data [146.185.181.9] npm WARN cannot run in wd meteor-dev-bundle@0.0.0 node npm-rebuild.js (wd=/bundle/bundle/programs/server) [146.185.181.9] => Starting meteor app on port:80 [146.185.181.9] WARNING: npm peer requirements (for react-meteor-data) not installed: [146.185.181.9] - react@15.x not installed. [146.185.181.9] - react-addons-pure-render-mixin@15.x not installed. [146.185.181.9] [146.185.181.9] Read more about installing npm peer dependencies: [146.185.181.9] http://guide.meteor.com/using-packages.html#peer-npm-dependencies [146.185.181.9] [146.185.181.9] [146.185.181.9] /bundle/bundle/programs/server/node_modules/fibers/future.js:267 [146.185.181.9] throw(ex); [146.185.181.9] ^ [146.185.181.9] Error: Can't find npm module 'react'. Did you forget to call 'Npm.depends' in package.js within the 'modules-runtime' package? [146.185.181.9] at Object.Npm.require (/bundle/bundle/programs/server/boot.js:195:17) [146.185.181.9] at options.fallback (packages/modules-runtime/modules-runtime.js:21:1) [146.185.181.9] at require (packages/modules-runtime/.npm/package/node_modules/install/install.js:81:1) [146.185.181.9] at meteorInstall.node_modules.meteor.react-meteor-data.createContainer.jsx (packages/react-meteor-data/createContainer.jsx:5:1) [146.185.181.9] at fileEvaluate (packages/modules-runtime/.npm/package/node_modules/install/install.js:141:1) [146.185.181.9] at require (packages/modules-runtime/.npm/package/node_modules/install/install.js:75:1) [146.185.181.9] at meteorInstall.node_modules.meteor.react-meteor-data.react-meteor-data.jsx (packages/react-meteor-data/react-meteor-data.jsx:7:25) [146.185.181.9] at fileEvaluate (packages/modules-runtime/.npm/package/node_modules/install/install.js:141:1) [146.185.181.9] at require (packages/modules-runtime/.npm/package/node_modules/install/install.js:75:1) [146.185.181.9] at packages/react-meteor-data/createContainer.jsx:10:16 

En estos loggings, leí algo sobre que React no está instalado. Pero, por lo que puedo ver, instala Telescope en un contenedor Docker, y realmente no sé cómo puedo instalar la reacción dentro de ese contenedor.

¿Alguien tiene alguna idea de lo que puedo hacer para arreglar esto?