instalar pip3 en ubuntu 12.04 docker image

Estoy tratando de instalar e instalar pip3 en la image del acoplador. La configuration inicial utilizada es

FROM ubuntu:12.04 MAINTAINER Candidate @ Ctx <candidate@caltex.com.au> LABEL "name"="Troubleshooting Test" USER root ENV PY_DIR /home/dev

Después de referirme a algunas publicaciones ( https://askubuntu.com/questions/412178/how-to-install-pip-for-python-3-in-ubuntu-12-04-lts ) sobre esto sigo los siguientes pasos:

 RUN apt-get update && apt-get install -y \ software-properties-common python-software-properties RUN add-apt-repository ppa:fkrull/deadsnakes RUN apt-get update && apt-get install -y \ python3 \ build-essential \ python3-setuptools \ python-dev RUN easy_install3 pip 

La salida es abrupta y contiene:

 File "build/bdist.linux-x86_64/egg/pip/_vendor/progress/spinner.py", line 32 phases = [u'\u25f7', u'\u25f6', u'\u25f5', u'\u25f4'] ^ SyntaxError: invalid syntax 

También cuando uso pip3 tiene un problema similar. Intenté instalarlo con el command: apt-get install python3-pip

Pero eso tampoco funciona. Por favor sugiere una solución.

Su problema es que está tratando de instalar la última versión de pip en una versión de Python no compatible. La versión disponible es

versiones: 0.2, 0.2.1, 0.3, 0.3.1, 0.4, 0.5, 0.5.1, 0.6, 0.6.1, 0.6.2, 0.6.3, 0.7, 0.7.1, 0.7.2, 0.8, 0.8. 1, 0.8.2, 0.8.3, 1.0, 1.0.1, 1.0.2, 1.1, 1.2, 1.2.1, 1.3, 1.3.1, 1.4, 1.4.1, 1.5, 1.5.1, 1.5.2, 1.5.3, 1.5.4, 1.5.5, 1.5.6, 6.0, 6.0.1, 6.0.2, 6.0.3, 6.0.4, 6.0.5, 6.0.6, 6.0.7, 6.0.8, 6.1.0, 6.1.1, 7.0.0, 7.0.1, 7.0.2, 7.0.3, 7.1.0, 7.1.1, 7.1.2, 8.0.0, 8.0.1, 8.0.2, 8.0. 3, 8.1.0, 8.1.1, 8.1.2, 9.0.0, 9.0.1

La solución es usar la versión con trabajos

 RUN easy_install3 pip==7.1.2 

Desde 8.0.0 puede ver el problema que está enfrentando ahora